Unplanned Outage - RMC

Incident Report for KPA

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 08:35 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 07:56 MDT

Investigating

Users are unable to access the systems listed below. The KPA Technology team is currently looking into the issue.
Posted Jul 01, 2025 - 05:00 MDT
This incident affected: Risk Management Center (Admin Portal).