Unplanned Outage - KPA Flex
Incident Report for KPA
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 12:31 MDT
Update
We are currently experiencing slower-than-usual performance in certain areas of the application, including Dataloading and Forms. Our team is actively investigating the issue and working to restore full functionality as soon as possible.

We will provide an update as soon as the situation is resolved and performance is back to normal. Thank you for your patience.
Posted Sep 24, 2024 - 11:16 MDT
Investigating
Users are experiencing slow page loads or timeouts with forms submissions for the systems listed below. The KPA Technology team is currently looking into the issue.
Posted Sep 24, 2024 - 10:29 MDT
This incident affected: Flex (Application, API).